:
Destination Time
:
Present Time
:
Last Time Departed
Carlos_McFly

Quick fixes for some issues

Recommended Posts

Since I have a lot of free time :v I'm sharing with you some fixes and adjustments I've made to the script. They include:

Not a big deal, just some value changes and a few lines of code added. Please let me know what you think and if they worked for you.

main.sc

main.scm

Timetravel.sc

Environment.sc

HillValley.sc

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Carlos_McFly said:

Since I have a lot of free time :v I'm sharing with you some fixes and adjustments I've made to the script. They include:

Not a big deal, just some value changes and a few lines of code added. Please let me know what you think and if they worked for you.

main.sc

main.scm

Timetravel.sc

Environment.sc

HillValley.sc

Now it works!!! Clocktower mod is working!

But there's traffic in Hill Valley again.

Edited by AlexPasetto

Share this post


Link to post
Share on other sites

But why i can't longer take the plutonium from the landfill after the first time?

Edited by Marty85

Share this post


Link to post
Share on other sites

Thank you!!! I can confirm that the lightning strike works without crash. I tried it at least a dozen times and it never froze.

But Alex is correct, there is still traffic in Hill Valley after 21:00. If you can fix that it would be perfect!!

Edited by bttf4ever

Share this post


Link to post
Share on other sites

Moved the topic to a more fitting location. The bug section is for tracking specific bugs.

  • Like 1

Share this post


Link to post
Share on other sites

I figured it out! I neglected to replace the original main.scm file (in the data folder) with yours. Your fixes work fantastic now! 

Edited by bttf4ever
  • Like 1

Share this post


Link to post
Share on other sites
13 hours ago, Carlos_McFly said:

Since I have a lot of free time :v I'm sharing with you some fixes and adjustments I've made to the script. They include:

Not a big deal, just some value changes and a few lines of code added. Please let me know what you think and if they worked for you.

main.sc

main.scm

Timetravel.sc

Environment.sc

HillValley.sc

That's brilliant.  This is the way it should be, any fixes that are posted should include the source files :)

  • Like 1

Share this post


Link to post
Share on other sites
10 hours ago, Mini-Me said:

Moved the topic to a more fitting location. The bug section is for tracking specific bugs.

Thanks, at first I was hesitating about what section I had to post this. xd

6 hours ago, Mike said:

That's brilliant.  This is the way it should be, any fixes that are posted should include the source files :)

Glad you liked it Mike :D If I find other bugs, I'll try to fix them by my own and share with you what I do.

Share this post


Link to post
Share on other sites
59 minutes ago, Omega said:

I tried running it with the posted fix files but the crashes when lightning hits the clock tower still continues.

Did you replace all of the files in the _src\gamescript directory? Also make sure to replace main.scm in the data folder as well.

Edited by bttf4ever

Share this post


Link to post
Share on other sites

I did the lightning run in RC mode with the fixes and ended up getting a DeLorean back with the lightning rod still attached and that vented. Not sure whether it's a bug with your code or whether it's a stock mod thing, seeing as how I could never, ya know, do the lightning run before. Just a heads up.

Share this post


Link to post
Share on other sites
4 hours ago, bttf4ever said:

Did you replace all of the files in the _src\gamescript directory? Also make sure to replace main.scm in the data folder as well.

I did indeed, first I tried just replacing the src gamescripts, the crash still happened, and then I replaced the main.scm in the data folder and crashed when applying the hook to the time machine.

Share this post


Link to post
Share on other sites
3 hours ago, Omega said:

I did indeed, first I tried just replacing the src gamescripts, the crash still happened, and then I replaced the main.scm in the data folder and crashed when applying the hook to the time machine.

The crash when applying the hook to the car is a common issue that has been around for a while. Either put the hook on immediately after getting the car from the garage or save your game in Hill Valley and then immediately restore from that saved game and try to put the hook on there, that usually works for me.

Share this post


Link to post
Share on other sites
4 hours ago, hscitpe said:

I did the lightning run in RC mode with the fixes and ended up getting a DeLorean back with the lightning rod still attached and that vented. Not sure whether it's a bug with your code or whether it's a stock mod thing, seeing as how I could never, ya know, do the lightning run before. Just a heads up.

Yeah, that bug was there even before the first update. That happened to me too the only time I could make it work when 0.2f was released.

Share this post


Link to post
Share on other sites
On 11/17/2015 at 7:07 PM, Carlos_McFly said:

Since I have a lot of free time :v I'm sharing with you some fixes and adjustments I've made to the script. They include:

Not a big deal, just some value changes and a few lines of code added. Please let me know what you think and if they worked for you.

main.sc

main.scm

Timetravel.sc

Environment.sc

HillValley.sc

Where do i put them? all of them goes on data folder?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...