Destination Time
Present Time
Last Time Departed

GTA BTTF SA Not working

Recommended Posts

I downloaded and installed the BTTF Mini Mod with no problems. But when I click New Game or Load game, game is loading to the middle and then crashes. Anyone knows what can be this problem? :)

I tried reinstall the game or reinstalling the mod, nothing works.

errordump.txt file:

GTA:SA Crashed, Debug Info Follows:
GTA Info:
Version: US 1.0
Last File Loaded: errordump.txt
Last Library Loaded: C:\WINDOWS\system32\nvspcap.dll
Error: Unknown
Assembly Info:
Exception At Address: 0x68B37001
Exception Code: 0xc0000005 (EXCEPTION_ACCESS_VIOLATION)
EAX: 0x68B37001 EBX: 0x0182D834
ECX: 0x00000000 EDX: 0x00000000
ESI: 0x7FFDE000 EDI: 0x00000003
EBP: 0x0028E12C ESP: 0x0028E108

Share this post

Link to post
Share on other sites

Do some system checks:

Check 1:

Go to the desktop (not the metro start screen)

Make sure you are always running GTA SA as administrator. If not, check your virtualstore folder. C:\Users\YOURUSERNAME\AppData\Local\VirtualStore\Program Files (x86)\PathtoGTASA

To access the AppData folder, show all hidden files and folders.

If your PathtoGTASA folder exists, delete it, then uninstall and reinstall GTA SA (making sure you run the installer as administrator as well). You may be forced to exit the autorun installer from the disk and run the setup.exe as administrator.

Check 2:

Make sure DEP (data execution prevention) is turned off.


From Microsoft:
  1. Open System by clicking the Start button 4f6cbd09-148c-4dd8-b1f2-48f232a2fd33_818, right-clicking Computer, and then clicking Properties.

  2. Click Advanced system settings. 18abb370-ac1e-4b6b-b663-e028a75bf05b_48. If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  3. Under Performance, click Settings.

  4. Click the Data Execution Prevention tab, and then click Turn on DEP for all programs and services except those I select.

  5. To turn off DEP for an individual program, select the check box next to the program that you want to turn off DEP for, and then click OK.

    If the program is not in the list, click Add. Browse to the Program Files folder, find the executable file for the program (it will have an .exe file name extension), and then click Open.

  6. Click OK, click OK in the System Properties dialog box if it appears, and then click OK again. You might need to restart your computer for the changes to take effect.

Please do these system checks and then reinstall the game making sure that you fix the problems stated above. Then, reply back to this topic.

Share this post

Link to post
Share on other sites

Sometimes I have the same problem, most recently is when I run the steam version without downgrading it. If you're running the steam version of SA then you'll have to look for a way of making it version 1.0, as this (I believe) is the only mod friendly version. I'm not sure which one I used but if you look on the internet (or maybe even this site) then you'll find one.

Share this post

Link to post
Share on other sites

I forget, 2 or 3 months away a had a 3 years old laptop with Windows 7 and the mod worked perfectly on the laptop. But now I have new laptop with windows 8 and not work. And I forget that if I click with right mouse button on GTA_SA.exe, I have set the compatibility to windows 7 and run as administrator, (when i dont do this the game wont start) when I set it the game run. I tried the all two mods (BTTF Mini Mod and BTTF MOD by delorean88mp) nothing work.

Reply to Agent 86 - (your Back in Time serial is good :D)

The pathtoGTASA is not there. The DEP is turned OFF.

Edited by Krystof11cze

Share this post

Link to post
Share on other sites

Windows tries to protect files that are stored in the Programs directory. You could try moving the GTA SA directory to C:\Games or something.

Also renaming gta_sa.exe to anything else, stopps Windows from trying to perform some so-called compatibility tweaks, which can be bad for modding. On Win7, I have renamed gta_sa.exe to gta-sa.exe, so the stupid Game Explorer won't try to access the internet just to download a jpeg of GTA SA's cover art. Plus, the Game Explorer process can take up to 100% CPU usage if connection failed and there is no time-out.

Get WinXP! That works with pretty much no tinkering.

Share this post

Link to post
Share on other sites

Glad I could help.

What was the solution? Moving the GTA:SA directory or renaming the EXE?


Keep in mind, to use my edits of the mod, you need to very carefully read both ReadMe files, the one that comes with the original mod and mine.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.