:
Destination Time
:
Present Time
:
Last Time Departed
BTTFModMachine

Back To The Future: San Andreas Modifications by BTTFModMachine

Recommended Posts

Hey, can someone help me out with this coding problem (once again)?

I'm trying to change the train_trail script so that the BTTF3RR delorean is actually a train (so that it stays on the tracks). I used the San Andreas train limiter and changed Train Type 2 so that the locomotive is using the model #INFERNUS (yes, you can change a train so that it becomes a car model).

However, a minute after I start the game, it crashes. Can someone tell me why this is happening? Here's my code:

thread 'TRAIN_TRAIL' 

:TRAIN_TRAIL_19
   not Player.Defined($PLAYER_CHAR)
else_jump @TRAIN_TRAIL_42 
wait 0 
jump @TRAIN_TRAIL_19 

:TRAIN_TRAIL_42
6@ = Audiostream.Load("CLEO\AUDIO\BTTF3_RAILROAD\GO.MP3")
7@ = Audiostream.Load("CLEO\AUDIO\BTTF3_RAILROAD\START.MP3")

:TRAIN_TRAIL_123
wait 1 
   Player.Defined($PLAYER_CHAR)
else_jump @TRAIN_TRAIL_123 

:TRAIN_TRAIL_139
wait 1 
   Player.Controllable($PLAYER_CHAR)
else_jump @TRAIN_TRAIL_139 
//0AB4: 0@ = var 8 
  // not Car.Wrecked(0@)
//else_jump @TRAIN_TRAIL_139 
//if and
 //  Car.Model(0@) == #INFERNUS
 //  Actor.InCar($PLAYER_ACTOR, 0@)
//else_jump @TRAIN_TRAIL_139 
Model.Load(#FREIGHT)
//Model.Load(#FREIFLAT)
Model.Load(#INFERNUS)
038B: load_requested_models 

:TRAIN_TRAIL_208
wait 0 
if and
   Model.Available(#FREIGHT)
 //  Model.Available(#FREIFLAT)
 Model.Available(#INFERNUS)
else_jump @TRAIN_TRAIL_208 
0AB4: 23@ = var 7 
00BF: 24@ = current_time_hours, 7@ = current_time_minutes 
24@ *= 100 
005A: 24@ += 25@ // (int) 
//06D8: 5@ = create_train_at 730.3469 2430.528 19.74293 type 15 direction 0 
1@ = 730.3469
2@ = 2430.528 
3@ = 19.74293
//0407: store_coords_to 1@ 2@ 3@ from_car 5@ with_offset 0.0 10.0 0.0 
06D7: enable_train_traffic 0 
06D8: 0@ = create_train_at 1@ 2@ 3@ type 2 direction 0 
26@ = Car.Angle(0@)
0A92: create_custom_thread "TIMETRAVEL_BTTF3_R.S" 0@ 0 2 23@ 24@ 23@ 24@ 0 0 0 0 1@ 2@ 3@ 26@  
Model.Destroy(#FREIGHT)
//Model.Destroy(#FREIFLAT)
Model.Destroy(#INFERNUS)
//07BD: destroy_train 5@ 
0652: 20@ = integer_stat 181 
0629: change_integer_stat 181 to 4 
//4@ = Marker.CreateIconAndSphere(11, 1@, 2@, 3@)

:TRAIN_TRAIL_318
wait 1 
   Player.Controllable($PLAYER_CHAR)
else_jump @TRAIN_TRAIL_10398 
//0AB4: 0@ = var 8 
   not Car.Wrecked(0@)
else_jump @TRAIN_TRAIL_10398 
   Actor.InCar($PLAYER_ACTOR, 0@)
else_jump @TRAIN_TRAIL_10398 
0629: change_integer_stat 181 to 4 
if and
0103:   actor $PLAYER_ACTOR in_sphere 1@ 2@ 3@ radius 2.0 2.0 2.0 sphere 1 stopped_in_car 
0AB0:   key_pressed 84 
else_jump @TRAIN_TRAIL_318 
//Marker.Disable(4@)
03BF: set_player $PLAYER_CHAR ignored_by_everyone 1 
0169: set_fade_color_RGB 0 0 0 
fade 0 750 
wait 750 
0AB3: var 826 = 7 
0AB3: var 800 = 2 
0826: enable_hud 0 
0581: enable_radar 0 
Model.Load(#FREIGHT)
//Model.Load(#FREIFLAT)
038B: load_requested_models 

I don't think anything executes beyond this point. Thanks!

Share this post


Link to post
Share on other sites

Hey, I just made my first scratch made CLEO script! Too bad it doesn't work. :P

I noticed in the BTTF movies that the delorean makes certain sound effects randomly (usually when accelerating and decelerating). I tried to replicate this in CLEO. However, whenever I press the keys listed below in the delorean, the game crashes:

// This file was decompiled using SASCM.ini published by GTAG (http://gtag.gtagaming.com/opcode-database) on 14.6.2013
{$CLEO .cs}

//-------------MAIN---------------
thread 'DELOS' 
//0AB4: 20@ = var 909 //I tried both of these audio opcodes (they gave me trouble with the KR mod)
20@ = Audiostream.Load3D("CLEO\AUDIO\DELOS.MP3")

:DELOS_11
wait 0
if
Player.Defined($PLAYER_CHAR)
jf @DELOS_11
jump @DELOS_13

:DELOS_13
wait 0
if or
Actor.DrivingVehicleType($PLAYER_ACTOR, #ALPHA)
Actor.DrivingVehicleType($PLAYER_ACTOR, #HOTKNIFE)
Actor.DrivingVehicleType($PLAYER_ACTOR, #INFERNUS)
Actor.DrivingVehicleType($PLAYER_ACTOR, #SUPERGT)
Actor.DrivingVehicleType($PLAYER_ACTOR, #BANDITO)
jf @DELOS_15
jump @DELOS_17

:DELOS_15
wait 0
if or
Actor.DrivingVehicleType($PLAYER_ACTOR, #HOTRINA)
Actor.DrivingVehicleType($PLAYER_ACTOR, #HOTRINB)
Actor.DrivingVehicleType($PLAYER_ACTOR, #PHOENIX)
Actor.DrivingVehicleType($PLAYER_ACTOR, #HOTRING)
Actor.DrivingVehicleType($PLAYER_ACTOR, #SLAMVAN)
jf @DELOS_11
jump @DELOS_17

:DELOS_17
wait 0
0@ = Actor.CurrentCar($PLAYER_ACTOR)
if
Actor.InCar($PLAYER_ACTOR, 0@)
jf @DELOS_11
if or
00E1:   player 0 pressed_key 16 //accelerate key
00E1:   player 0 pressed_key 14 //brake key
jf @DELOS_11
0209: generate_random_int_in_range 30000 60000 store_to 1@
wait 1000
gosub @DELOS_21
wait 1000
jump @DELOS_11

:DELOS_21
wait 1@
Audiostream.PerformAction(20@, STOP)
Audiostream.LinkToCar(20@, 0@)
Audiostream.PerformAction(20@, PLAY)
return

Can anyone tell me why the game is crashing? I would really appreciate some help with this.

Thanks.

Edited by BTTFModMachine

Share this post


Link to post
Share on other sites

Don't know why it's crashing but this seems to be unused?

0209: generate_random_int_in_range 30000 60000 store_to 1@
  • Like 1

Share this post


Link to post
Share on other sites

Actually, I'm using the random int generator to wait a random amount of time. Then, the sound plays.

:DELOS_21
wait 1@
Audiostream.PerformAction(20@, STOP)
Audiostream.LinkToCar(20@, 0@)
Audiostream.PerformAction(20@, PLAY)
return

Share this post


Link to post
Share on other sites

hello modmachine!

you can release a autoistaller with all updates included?

you can fix teleport script beta 1-2-3

1-2=do not see the time circuit

3=crash game

i would be glad if you could answer me and help me! i love his mod

thanks bye

Share this post


Link to post
Share on other sites

new bugs teleport script beta 1-2-3

disappear after the first trip the circuit time then the next trip then reappars again and the next trip disappear

a trip and one not

fix please is full of bugs the mod :cry::cry::cry::cry::cry::cry::cry::cry::cry::cry::cry::cry::cry::cry:

Share this post


Link to post
Share on other sites

New Mod Update! See first post!

you're a genius,fantastic update you reeds fixed the time circuit,and the delorean is increasingly realistic! can not wait to try it lol :)

just out of curiosity how did you set up permissions?

  • Like 1

Share this post


Link to post
Share on other sites

CLEO scripts are open source, so anyone can edit them and post them anywhere.

I got permission from uokka to release his particle effects along with my scripts.

My updated scripts now have dependencies on mods that I do not have permission to release.

Share this post


Link to post
Share on other sites

CLEO scripts are open source, so anyone can edit them and post them anywhere.

I got permission from uokka to release his particle effects along with my scripts.

My updated scripts now have dependencies on mods that I do not have permission to release.

but in the future you release something?

Share this post


Link to post
Share on other sites

Good job on the lights. I started doing this too but was too lazy to finish that filigree stuff. Looks great at night. You could also link the inactive yellow side lights (which aren't indicators as I've been told) to the front lights.

The roof between the doors is bumpy. I had that too when setting the normals (or whatever it's called) automatically on the hole model. That sucks. fix it. q:

  • Like 1

Share this post


Link to post
Share on other sites

Thanks. I actually had to improvise my own texture for the lights. I used the crysis delorean delorean_hull_other texture as a base and dropped a headlight texture from vehicle.txd on there. I also had to remap the headlights and front turn lights. I don't know what texture uses the yellow side lights.

The adaptation process is long and tedious (as you know) because every time I make a change, I have to re-map the rear lights and turn lights. ZModeler breaks your model if you export and import. I don't know if I want to touch this model any more (unless I can figure out how to fix ZMod). :blink:

Share this post


Link to post
Share on other sites

You could make the yellow side lights use the same color mask as the front lights and remap to the vehiclelights texture. Without IVLM dummies.

You need a version of ZM that can handle project files rather then importing a dff.

Doesn't it cost only a few bugs?

Edited by uokka
  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...