:
Destination Time
:
Present Time
:
Last Time Departed
uokka

uokka's modified "BttF SA Mod"

Recommended Posts

Im not sure if i understand your question correctly.

Time travel effects are getting activated on reaching a certain speed value, and getting deactivated, if the speed falls below this value.

So the speed doesnt really matter..

Share this post


Link to post
Share on other sites

Can you made a install program for the mod i can give you a good.

And sorry when i read over a few topics because iam too lazy too read this all.

And my English is not so good :D .

Share this post


Link to post
Share on other sites

No, I wont. My stuff is only minor edits to the mod.

If you wanna use it, you need to know a little about cleo coding and/or SA modding.

Only the mod team should release BttF Mod installers.

Im not part of the mod team.

Share this post


Link to post
Share on other sites

this is amazing stuff...ive been following the mod and forums for a few years now..and occasionly you do get work by certain individuals..like STexture..or whatever his stupid name was...which is just copies or unauthorised use of other people's work..however when someone with your calibre of work comes into view..you just have to stare in amazement at the hardwork you guys can do...

I'd give anything to be able to code like you can...i would risk incorporating your edits to my game...but i can only just manage to replace the cleo folder for every source code update haha

I do have just one ... erm...question...the edits you've made do you have to create new cleo files for them or just simply edit an existing cleo file and then complie it?

Excellent work :)

Share this post


Link to post
Share on other sites
Im not sure if i understand your question correctly.

I'm talking about the final part of the sequence -- the time traveling / 'teleporting' through time / implosion / fire trails part. :P

See, as far as I can remember, the previous codes rely on speed for both the sequence and the final time travel itself. If you've moved the start of the sequence or the pre-time travel effects from 80 to 88, wouldn't the effects be short-lived since you'll also time travel at 88? Ain't sure about the current latest code, though.

Share this post


Link to post
Share on other sites

@rdc5288

Thank you. :blush:

I dont think i would have been able to do all this amazing stuff on my own..

I dont even know exactly how i managed to achieve all this! :lol:

Remember, i didnt created the mod. I've only edited it..

Im working on this since one year or so. It was, and still is hard work, indeed.

If you wanna be able to code like me, tweak some cleo scripts until nothing will work anymore.

Then try to repair it! Thats my style of learning how to code, which is a pain in the ass but it works.

The scripts from the first post are complete scripts (WIP).

Paste the code into empty txt files and compile with sanny.

NOTE: They work for me, but might not work correctly on default bttf sa v0.1.3.2..

You have to fix that yourself, which might be a pain in the ass.. :D

@daangelo29

The speed only initiates the time traveling effects. thats it.

If the speed does not go down and the wormhole reaches its full size, the time travel happens.

This needs about 1 second. You can even time travel while accelerating to more tha 88 MPH.

Does this answer your question?

Edited by uokka

Share this post


Link to post
Share on other sites

So the time travel is based on the size of the wormhole, then? This must be Blue/DeLorean88US's fix for time traveling instantly when activating the time circuits under speed of =>88MPH.

Sorry about these lazy questions. Sanny Builder and GTA:SA in general are currently acting like crap on me so I need to re-install everything before I could download and test the latest code -- which I don't have much time for 'till after my thesis defense this Monday.

Share this post


Link to post
Share on other sites
So the time travel is based on the size of the wormhole, then?

Kind of.. Time travel takes place in the code just after the wormhole has grown to its max size. And I can only talk about my scripts here. Im not very familiar with the original code anymore.

Sorry about these lazy questions.

No! Im glad about any kind of feedback.

EDIT:

I've just realized that was my fix ;)

Edited by uokka

Share this post


Link to post
Share on other sites

thanks for the info uokka, of course i meant edits...cant give you all the crdit can we ;) lol although ive not seen anything of blue on here for a while...be nice to see some updates on the next full build of BTTF SA...anyway just attempted compiling the lift off scipt and it dosent like the 0AC1 Opcode in "0AC1: 21@ = load_audiostream_with_3d_support "CLEO\AUDIO\BOOST.MP3" //IF and SET "

Any help on what to do?..tell ya i'm a complete noob...most ive done is change start date and time in GTA VC....dosent seem to work when doing it in SA.

Share this post


Link to post
Share on other sites

Can 'ya also tell us how you got the big light thing at 1:48 - 1:50 of your 5th video? It's something I was aiming for a year ago to improve the wormhole/implosion (for my own tastes, that is).

Share this post


Link to post
Share on other sites

I have seen in your videos that you have no Speed-o-Meter and i have edited a original script for this Display

SPOILER:
// This file was decompiled using sascm.ini published by Seemann (http://sannybuilder.com/files/SASCM.rar) on 13.10.2007

{$VERSION 3.1.0027}

{$CLEO .cs}

//-------------MAIN---------------

thread "SPDMTR"

1@ = 255

2@ = 50

3@ = 50

6@ = 1

:Speed

while true

wait 10

if

Player.Defined($PLAYER_CHAR)

jf continue

if

Actor.Driving($PLAYER_ACTOR)

jf continue

if

Actor.DrivingVehicleType($PLAYER_ACTOR, #SUPERGT)

jf continue

// Is player time travelling?

0AB4: 5@ = var 0

if

not 5@ == 1

jf continue

// Enables/disables speedometer

if and

32@ > 500

0AB0: key_pressed 0xDB // '['

then

6@ *= -1

6@ += 1

32@ = 0

end

// If speedometer is enabled, draw speedometer

if

6@ == 1

jf continue

03C0: 0@ = actor $PLAYER_ACTOR car

02E3: 4@ = car 0@ speed

4@ *= 2.236936

008C: 4@ = float 4@ to_integer

gosub @Draw

033F: set_text_draw_letter_size 2.0 8.0

03E4: enable_text_draw_align_right 1

// Pads output with zeroes if < 10

if

4@ > 9

then

045A: draw_text_1number 600.0 375.0 GXT "SPEED" number 4@

else

045A: draw_text_1number 600.0 375.0 GXT "SPEED1" number 4@

end

end

//----------------Functions----------------//

:Draw

0340: set_text_draw_RGBA 1@ 2@ 3@ 255

0341: unknown_text_draw_flag 1

03E4: enable_text_draw_align_right 0

0343: set_text_draw_linewidth 5000.0

0348: enable_text_draw_proportional 1

0342: enable_text_draw_centered 0

0345: enable_text_draw_background 0

033F: set_text_draw_letter_size 0.5 1.8

return

And this is the FXT File

SPOILER:
SPEED ~1~.

SPEED1 0~1~.

Share this post


Link to post
Share on other sites

@rdc5288

Reading through the topic might help.

@daangelo29

The big light is part of the searchlights. Just like on police heli

@Delorean12

What did you change in speed.cs?

Share this post


Link to post
Share on other sites

So the light is a corona? I'm wishing to use something like it for the implosions/explosions and also perhaps the wormhole. The command for displaying a corona must be constantly used to keep it displayed, so it may not be the best for implosions/explosions. As for wormholes, though, I've already tried it. Although shiny and beautiful (to me), it ain't good with lags.

And speaking of, my defense ain't done yet. Our panelists asked us to improve the software and re-report it by Friday. So no GTA:SA modding for me 'till Saturday. Bummer.

Share this post


Link to post
Share on other sites

Oddly enough,none of the scripts work for me,wonder why...i have CLEO 4 and everything. Anyway,awesome job on the mod uokka :D

Nevermind,fixed the boost and the unflip script,but the game crashes when i press submission(liftoff script)

Edited by Driver 12

Share this post


Link to post
Share on other sites

You could attach a searchlight to the DeLorean whitch aims to the cam/view point with a little offset. So you would look directy into the light and getting blended. The searchlight beam might be laggy but not the searchlight corona.

The command for displaying a searchlight does not have to be used constantly to keep it displayed.

Share this post


Link to post
Share on other sites

So it ain't a corona then? 'Cuz coronas in CLEO need to be constantly told to display to display longer. And you can't attach it to objects like how you can attach the coil glow effects on the De Lorean without any lags affecting them. Coronas 'attached' to the De Lo would function like the effects in the GTA:VC mod.

I MIGHT just be able to mod GTA:SA a bit today. Just re-installed it, and everything seems to be working fine now. And if my group mates want their lead programmer to take a rest today and continue it tomorrow, why not? :)

Share this post


Link to post
Share on other sites

Its not a corona. It has nothing to do with 'create_corona' opcode. The laggyness of coronas comes from 10 miliseonds waits, until the cars world coords are updated in the cleo code, to spawn the next corona. You cannot use wait 0, as it falls back to a value of 10, i believe.

Wesser came up with a method which doesnt have this problem. I was using it for the green ground reflection (video #3 & #4) wich as well would be laggy in standard way of coding (as in video #5).

I removed it, because it produces other bugs..

By the way, see the DeLoreans taillights and its ground refection in video #3 & #4? Lagless..

Theres a Turn Indicators cleo script that uses a function to attach coronas to vehices! I didnt understand it yet, though.

Share this post


Link to post
Share on other sites
that uses a function to attach coronas to vehices! I didnt understand it yet, though.

Holy crap. *Hits download button*

EDIT: And so, what is it then? The only thing I've done properly is a custom particle (via effects.fxp), but at certain sizes and camera angles it becomes a bit less flash-y or bright so it ain't that pretty. It's almost close, but sadly not pretty enough. :(

Share this post


Link to post
Share on other sites

Yeah! If you found out how it works, please tell me. I dont know where all these parameters come from..

@rdc5288, @Driver 12

Try to remove audio stuff. If that doesnt work, you are on your own.

I didnt made it to be compatible with the original mod.

If you wanna use it, you need to fix it your self, sorry.

If I know the reason for the crash, i will post it here. But thats not my priority right now.

Sorry again.. Good luck.

Share this post


Link to post
Share on other sites

I think I get what you're saying. This is the one, right? --

Kinda clever in your part, imo. Never thought of using searchlights as time travel effects. I might either go with this, or continue learning how to properly create effects in effects.fxp.

EDIT: Just saw the code of the Turn Indicator mod. Looks like he used a lot of memory hacks. Currently beyond what I know.

Share this post


Link to post
Share on other sites

Yes thats the same effet im using for my landing pyramid. You can kinda connect two vehicles with a searchlight which is lagless. Using world coords lags.

Too bad for the memory stuff. Maybe i'll give it anoter try sometime.

Share this post


Link to post
Share on other sites

thanks uokka, found that i had cleo 3 installed...thought i updated to cleo 4 ages ago but must have reinstalled at somepoint...at 23 years old ur memory starts to go lol, ive just copied the bttf lift off and hover scripts...compiled fine thanks to new cleo 4 lol but do i have to remove any original cleo scripts from the installation of bttf sa..or like u say does it involve some slight modifications to the files...advice please..i promise i am learning this stuff slowly lol

Share this post


Link to post
Share on other sites

Im a little worried that cleo global variables messes things up.

For example: On activating hover mode, one variable, which can be used by all scripts (cleo global variable), gets its value changed from 0 to 1, so other scripts know when were flying. However, the script doesnt know its not the sparrow which is flying at this moment, but a car. This could be problematic, as models are getting attached to the vehicle and other stuff happens that we dont need..

Try changing the global variables which toggles the flying mode in BttF_DMC_Liftoff.cs and BttF_Hover_Anim.s, so that timetravel.s (which swaps your vehicle into a heli) dosnt do anything when activating my hover mode. There is a list of global variables in init.cs or rather its plain source init.txt. Choose a unused number/variable and replace it whith the global var for hovering and anim in BttF_DMC_Liftoff.cs and BttF_Hover_Anim.s.

The Boost also uses a global variable, but shouldnt be responsable for any crashes, i believe..

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...