:
Destination Time
:
Present Time
:
Last Time Departed
Sign in to follow this  
Kirok

IMG Tool Error

Recommended Posts

Hey guys,

I downloaded the PDF tutorial and followed everything... but when I got to rebuilding the gta3 image file with Image Tool 2, it said an "image maybe already in use", and didn't do a thing. This was on my Vista machine.

So...

I did a hard reboot; same error. Re-installed IMG Tool 2, and same thing. I came to the conclusion it MIGHT be a XP/Vista issue, so I took the image file to my XP machine, tried the same thing, and it had some sub commands in there for the root directory, so I was screwed with XP too. I saw the IMG tool program is four years old, so that was hard evidence of a XP/Vista issue.

Any suggestions or ideas?

Thanks!

Kirok

Share this post


Link to post
Share on other sites

Thank you, Mike. I appreciate that!

However, this issue was part two of a bigger one... saving my games and progress.

I wasn't able to save games, so I thought perhaps I needed some updates or patches. Thus, this is what began my IMG tool issue.

I am able to save games, but cannot load them later.

I get the option to choose the game file... black screen with "loading" appears, then an error window pops up behind the game saying there was an address error. I can grab a screen grab of that error if it will help.

Many thanks, Mike!

Kirok :)

Share this post


Link to post
Share on other sites

Please note that you cannot load a previously saved game. You can save a new game once the mod is installed, but, before you save, make sure you turn the time circuits off, and also make sure you are not in a vehicle when you save.

Share this post


Link to post
Share on other sites

No problem. If it helps any, I just threw this together as a guide for people installing the mod under Windows Vista/Windows 7 - though there is no reason that most of it shouldn't work for Windows XP also (except Step 2 :P)

" width="600px" height="361px">
" />

I've only just finished uploading it, as such it's still processing at the moment, the picture quality of the video should improve once YouTube has finished processing it.

Cheers, Mike

Share this post


Link to post
Share on other sites

@Mike: You should've asked me to help on this guide before you made it. :P

It is possible to install the mod in the Program Files folder, in two ways:

1. Disable UAC completely before installing (then re-enable it after)

2. Simply run the setup with administrator privileges (login with an administrator user account > right-click setup > click "Run As Administrator".

...though installing it outside the PF folder is easier.

Note that you only need to "Run As Administrator" if User Account Control is turned on (Vista) or set in the highest setting (Windows 7). Programs that the installer would run when the installer's run with admin privileges would end up the same. If you're using a non-admin account, Windows would ask you for one of the admins' password to proceed with the installation. Everything else should turn out fine after that.

You may also want to do the same with running the game itself to make sure Windows won't block any activity the game would do like saving.

As for setting the compatibility to Windows XP, it is no longer necessary. In fact, in some cases, setting it to XP compatibility would cause issues instead of fixing them.

Share this post


Link to post
Share on other sites

@Kirok - Are you saving the game using one of the default save points in the game OR are you using the save anywhere feature? It is also worth noting that you will want to put gta-vc.exe into compatibility mode for Windows XP as mentioned by angelo.

@angelo - I think the method posted is by far the easiest way for newbies to install the mod, without messing around with UAC settings, which would have taken longer to explain anyway. As stated in the video step 2 was performed 'just in case'.

I must admit I completely forgot to do gta-vc.exe which WILL need putting into compatibility mode in order to play properly. I will add a note to the end of the video stating to do that.

Though, I myself just install it straight to program files, without doing any of the stuff shown in the video, and I'm using Windows 7 Ultimate 64-bit with UAC turned on, go figure huh, no issues for me.

I do have to run other (non mod related) programs in compatibility mode to get them to install/run correctly, and personally, I have never once seen an issue from setting something to run in compatibility mode.....

Share this post


Link to post
Share on other sites

Mike,

I save my progress at random points, whenever I think about it.

Also, Angelo said "As for setting the compatibility to Windows XP, it is no longer necessary. In fact, in some cases, setting it to XP compatibility would cause issues instead of fixing them."

I wonder what I should do?

Thank you,

Kirok

Share this post


Link to post
Share on other sites

He was referring to the setup file not gta-vc.exe. Though in my experience, I have never seen an issue from using compatibility mode on setup files.

I assume you are not trying to load an old saved game from a time before you had the mod installed? It is important to now that old saved games will not work in any form. Personally, I just start a new game each time, only takes a couple of minutes to get the DeLorean converted to a time machine anyways.

Share this post


Link to post
Share on other sites

Hi Mike,

Okay, I deleted all game files and ran the game in XP Compatibility mode with the game running as the administrator. I saved a new game, and loaded it...

It got to a few seconds into it, then froze.

Plus, the flying DMC now flies erratic and upside down. It was pretty funny to watch actually.

Any ideas?

Thanks for your help!

Kirok

Share this post


Link to post
Share on other sites

Not really, kinda out of ideas now.

Any particular reason why you can't just load a new game each time? That's what most of the team here do (excluding moderators).

Share this post


Link to post
Share on other sites

Yea, I guess I can just load a new game each time. Just wanted to see if I could save steps for progress. Its no biggie. I'm just thankful there is FINALLY a BTTF game that's awesome! I was scarred from teenage-dom when Nintendo put out that retched game in 90' or somewhere around that time. It was for the original NES system, and was just terrible.

Thanks though, Mike. I do appreciate it!

Kirok

Share this post


Link to post
Share on other sites
Also, Angelo said "As for setting the compatibility to Windows XP, it is no longer necessary. In fact, in some cases, setting it to XP compatibility would cause issues instead of fixing them."

Same may be said about XP compatibility, I believe.

For some reason, in Vista Service Pack 2, having programs in XP compatibility causes some running issues for some, if not many, programs. In Windows 7, I haven't encountered the same problem before when using the XP compatibility.

Share this post


Link to post
Share on other sites

Hmm didn't know where to put this and probably been asked before but will 0.2f have the option for the high poly cars or have they been removed?

Share this post


Link to post
Share on other sites

They haven't really been removed, so much as downgraded... But yea, the high poly versions of the cars won't be in 0.2f, but you can most likely add them yourself by extracting the high poly ones in 0.2e with IMG Tool, and adding them into the 0.2f .img with the same tool.

Edited by Joe Statler

Share this post


Link to post
Share on other sites
Same may be said about XP compatibility, I believe.

For some reason, in Vista Service Pack 2, having programs in XP compatibility causes some running issues for some, if not many, programs. In Windows 7, I haven't encountered the same problem before when using the XP compatibility.

Not to be breaking an invalid "rule", but XP is the best operating system as of yet, and I have VISTA, and my Dad has 7, we both concure that XP is the best around. *Plays Karate Kid Theme*.

Share this post


Link to post
Share on other sites
They haven't really been removed, so much as downgraded... But yea, the high poly versions of the cars won't be in 0.2f, but you can most likely add them yourself by extracting the high poly ones in 0.2e with IMG Tool, and adding them into the 0.2f .img with the same tool.

Yeah, about that, where if 0.2f? I haven't seen it for about 2 months. Aren't all the releases supposed to be on Oct 26 or so?

Share this post


Link to post
Share on other sites
Yeah, about that, where if 0.2f? I haven't seen it for about 2 months. Aren't all the releases supposed to be on Oct 26 or so?

No you dipsh*t. 0.2e was released on that date because it was supposedly ready to be released, which we all know it wasn't.

Edited by Joe Statler

Share this post


Link to post
Share on other sites
They haven't really been removed, so much as downgraded... But yea, the high poly versions of the cars won't be in 0.2f, but you can most likely add them yourself by extracting the high poly ones in 0.2e with IMG Tool, and adding them into the 0.2f .img with the same tool.

In the installer, you have the option to choose whether to install the high-poly vehicles (Full Install) or not (Lite Install). :)

Not to be breaking an invalid "rule", but XP is the best operating system as of yet, and I have VISTA, and my Dad has 7, we both concure that XP is the best around. *Plays Karate Kid Theme*.

Best for its security holes and super-hack-ability, yes. You might argue Windows XP's simplicity makes it the best, but that's actually both a good thing and a bad thing (if you know why it is the latter, refer to the first sentence of this paragraph). And your dad must be using Windows 7 Starter or something. :P

Share this post


Link to post
Share on other sites

I prefer XP over any other operating system. Not for security or anything but because I'm used to using XP for so long. I can't break away from it. Might sound really really really weird but I am lost without XP. I have tried Vista and 7. can't get used to it.

Share this post


Link to post
Share on other sites

Took me awhile to get used to 7, since I had never touched a computer running Vista. Yes, I skipped an entire OS. But I really do like that the status bar of a file transfer (to another HDD, or part of your HDD) is shown in the toolbar. And that when you hover over a app in the toolbar, it'll show a minimized version of the app's window and it's actually a real time image...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this