:
Destination Time
:
Present Time
:
Last Time Departed
bluespace88

GTA SA Troubleshooting Source: 20091009 or Higher

Recommended Posts

so single time machine when you had the coils, or multiple.

Coils is completely rewritten.

Old code:

:Coil

02E3: 1@ = car 0@ speed

0AB4: 30@ = var 1

0AB4: 31@ = var 12 

if or

  32@ < 1500

  30@ == 1

jf @CoilReset

if or

  32@ < 1500

  31@ == 0

jf @CoilReset

if or 

  32@ < 1500

  1@ > 35.8 

jf @CoilReset  

if

83CA:   not object 15@ exists 

jf @CoilReturn

15@ = Object.Create(18636, 0.0, 0.0, 0.0)

0681: attach_object 15@ to_car 0@ with_offset 0.0 0.0 0.0 rotation 0.0 0.0 0.0  

jump @CoilReturn



:CoilReset	

if

03CA:   object 15@ exists 

jf @CoilReturn

Object.Destroy(15@)

jump @CoilReturn  



:CoilReturn

return
New code
:Coil

02E3: 10@ = car 0@ speed

0AB4: 30@ = var 1

if 

  33@ > 1500

jf @CoilCreate

if  and

  30@ == 1

  33@ > 5000 

jf @CoilReset

if	

  10@ > 35.8 

jf @CoilReset  



:CoilCreate

if

83CA:   not object 27@ exists 

jf @CoilReturn

27@ = Object.Create(18636, 0.0, 0.0, 0.0)

0681: attach_object 27@ to_car 0@ with_offset 0.0 0.0 0.0 rotation 0.0 0.0 0.0  

jump @CoilReturn



:CoilReset	

if

03CA:   object 27@ exists 

jf @CoilReturn

Object.Destroy(27@)

jump @CoilReturn  



:CoilReturn

return

From what I see, either your 33@ is set to 0 constantly, or your speed is somehow very fast.

Share this post


Link to post
Share on other sites

and in order to time travel, these conditions must be met

//Time lag

if

  33@ > 5000

jf @TimeTravelReturn  

// Time Circuits

if 

  1@ == 1 

jf @TimeTravelReturn   

// Fuel

if

  2@ == 2

jf @TimeTravelReturn

02E3: 10@ = car 0@ speed

if 

  10@ > 39.5 

jf @TimeTravelReturn

Share this post


Link to post
Share on other sites

and a few minutes is very weird, as I certainly don't have anything that would take that long other then a second time machine out there somewhere.

Share this post


Link to post
Share on other sites

and these are the global variables in use

// Var 0: Time Travel Flag

// Var 1: Time Circuits On/Off

// Var 2: Fly

// Var 3: Destination MDY

// Var 4: Destination HM

// Var 5: Past MDY

// Var 6: Past HM

// Var 7: Current MDY

// Var 8: Delorean

// Var 9: Time Change

// Var 10: Confirm  

// Var 11: Mode

I can tell you the only ones that matter to time travelling are 0 and 1.

Share this post


Link to post
Share on other sites

Had a good go of the new source code ,mtm works a treat so far ,excellent work ,just don't forget to fill up Mr fusion before using "\" can get a little annoying !

Share this post


Link to post
Share on other sites

yep was worried that driving/flying a distance away would stop tm re-appearing in its previous position but that works n all ,only a small thing iv been noticing is sometimes get "sparks" sound effects and "time circuits on" sfx when turning on tc.Not sure at what point it does this just noticed it after a while.

yep i tried it again tt, mtm , nothing until i hover converted then the sparks sfx started up again randomly ! might just be my comp but i thought id let you know anyway.

Edited by Sandman

Share this post


Link to post
Share on other sites

Both single and multi. And it can happen before or after time travel, which makes it unrelated to this bug. They just turn on by themselves then stay like that until wait another couple of minutes.

When you have 2 or more DeLoreans, their coils lit up all at the same time, even though you weren't all spawned at the same time.

gallery7.jpg

Try my Sleep Mod, spawn a DeLorean or two, then accelerate time by sleeping. Just spawn them -- time travel or not, they'll lit up anyway. Note that after a few minutes, they'll turn on by themselves then turn off after another few minutes. I hope you'll get my point now.

Share this post


Link to post
Share on other sites
so that pretty much tells me PC's mtm bug was due to him not noticing the day was off xD

Oh I notice the time bug, like VC problem. I knew what day I sent a delorean.

Share this post


Link to post
Share on other sites

BUG-1.jpg

I always have this bug , the big blue wormhole stay after time traveling and the coil too but i remove it for the coil with old script and i will do the same things for the wormhole

Share this post


Link to post
Share on other sites

It's probably because of the Stargate mod. Having other mods would make conflicts with the BTTF mod -- the Gravity Gun, for instance, is capable of erasing one of the DeLoreans. I haven't encountered that bug yet.

Share this post


Link to post
Share on other sites

not that not the reason because even if i don't use stargate mod i have that bug , it's because he remove the reference of the particule and when he do that they stay attach on the car or sometimes they go to another car like mine old mod

Edited by zero

Share this post


Link to post
Share on other sites

Iv tried creating the other bugs but it ain't happening.As far as i can tell the only bug is the sfx one after tt and mtm then hover conversion .I don't know how far other people are pushing the game but i don't seem to be able to get the other bugs! so far anyway.

Share this post


Link to post
Share on other sites
not that not the reason because even if i don't use stargate mod i have that bug , it's because he remove the reference of the particule and when he do that they stay attach on the car or sometimes they go to another car like mine old mod

Well it ain't happening on mine. The only bug that occurs so far is the coils bug.

Share this post


Link to post
Share on other sites

i resolve that two bug so now it's cool XD

Share this post


Link to post
Share on other sites

Sounds like you had the old effects.fxp. Zero.

The new one has the wormhole just appear for 25 ms and then go away, even if it has its references removed. That way it doesn't come back to life, and behaves like particles in VC.

So if its not time travel, just wondering. Do you get any get any other effects when the coils are on angelo?

Sparks, I kinda expected it to be buggy. Since I didn't want one mtm delorean to stop another spark sound from playing.

Dammit, I know why you have that bug Angelo. The timer resets itself after a few minutes.

Share this post


Link to post
Share on other sites

No. The only side effect of the coil bug is the inability to time travel. The time circuits can still be turned on, you can switch to flight mode just fine (you still won't be able to time travel), Mr. Fusion is re-fuel-able, etc. When the coil bug turns off, everything goes back to normal.

Share this post


Link to post
Share on other sites

Angelo, change these lines

:TimeTravel

if

  33@ > 5000

jf @TimeTravelReturn  

33@ = 10000

It forces the timer to stay at 10 seconds, so it doesn't loop and cause the coils to randomly switch on, if my calculations are correct. (I didn't test it xD)

Only figured because 33@ is the only variable controlling time travel and coils.

Share this post


Link to post
Share on other sites

one more bug.

sometimes the flying delorean comes back with no wheels during outside time travel. Specifically when you time travel yourself to when its supposed to come back.

Share this post


Link to post
Share on other sites

And I guess this results in a crash when entering and trying to hover convert it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...